Na lekcjach dotyczących LOGO korzystamy z programu Logomocja.

Temat: Procedury pierwotne

Język Logo tworzą procedury pierwotne i funkcje.

Są to słowa, które Logo rozumie i wie, jak wykonać.

 

Słowniczek poleceń omawianych na lekcji:

polecenie znaczenie
np 50 przesuwa żółwia o podaną liczbę kroków
ws 50 przesuwa żółwia wstecz o podaną liczbę kroków
pw 45 obraca żółwia w prawo o podany kąt
lw 45 obraca żółwia w lewoo podany kąt
 cs  czyszczenie ekranu
wróć ustawia żółwia w pozycji wyjściowej
ukp "zielony ustala kolor pisaka
ukm "czerwony ustala kolor zamalowywania
pod podnosi pisaka
opu opuszcza pisaka
zamaluj zamalowuje obszar, w którym ustawiony jest żółw
okrąg 60 maluje okrąg o średnicy 60
koło 60 maluje koło o średnicy 60
 

Temat: Procedury wtórne

Procedurą wtórną nazywamy procedurę złożoną z procedur pierwotnych.

 

Budowa procedury wtórnej:

oto  nazwa_procedury    DEKLARACJA PROCEDURY
........
........                            TREŚĆ PROCEDURY
.......
 już                               ZAKOŃCZENIE PROCEDURY

 

Wywołanie procedury wtórnej następuje poprzez napisanie jej nazwy.

 

PRZYKŁADY:

 

 

oto trójkąt
np 60 pw 120 np 60 pw 120 np 60 pw 120
już

 

oto kwadrat
np 60 pw 90 np 60 pw 90 np 60 pw 90 np 60 pw 90
już

Temat: Realizacja pętli- iteracja

Wielokrotne powtórzenie procedur ujętych w nawiasy następuje po napisaniu polecenia:

 

POWTÓRZ   ile   [ lista procedur]

 

PRZYKŁADY:

 

oto trójkąt
powtórz 3 [ np 60 pw 120 ]
już

 

oto sześciokąt
powtórz 6 [ np 50 pw 60 ]
już

 

oto koło
powtórz 360 [ np 1 pw 1 ]
już

 

WNIOSEK:
Aby narysować n- wielokąt stosujemy procedurę:
powtórz n [ np  a   pw  360 / n ]

Na lekcji napisaliśmy procedurę rysującą "pawie oczko":

Temat: Procedury wtórne wzajemnie zależne

Jeżeli jedna procedura wtórna stanowi część treści innej procedury wtórnej, to mamy do czynienia z procedurami wtórnymi wzajemnie zależnymi.


Przykład

 

oto kwadrat
powtórz 4 [ np 40 pw 90]
już

 

oto serweta
powtórz 36 [kwadrat pw 10]
już

Przykład


oto okrąg
powtórz 180 [ np 2 pw 2 ]
już

 

oto motyw
powtórz 36 [okrąg pw 10]
już

Zadanie 

Sprawdź co zostanie narysowane, gdy napiszemy następujące procedury:

A)

 

oto sześć
powtórz 6 [ np 30 lw 60]
już

 

oto coś
powtórz 6 [sześć lw 60]
już

 

B)

 

oto gwiazda
powtórz 9 [ np 50 pw 160 ]
już

 

oto gwiazdki
powtórz 4 [gwiazda pw 90]
już

Zadanie - problem omawiane i zrealizowane na lekcji:

Napisz procedurę wtórną, wzajemnie zależną, która narysuje gwiazdę: